Why is Drupal saying that -> This version is not compatible with Drupal 7.x and should be replaced?

When Drupal displays "This version is not compatible with Drupal 7.x and should be replaced"  next to a theme, it means that your theme doesn't contain a region named 'content' defined in the theme's .info file.